津村彰氏によるコラム第7回「SWX2300をCLIで設定してみよう」

1. はじめに

前回のコラムで、「次回以降は、SWX2300シリーズについて、ハウツーを交えながらより具体的な使い方をご紹介して行ければと思います。また併せて、例えばCCENT/CCNA取得者がSWX2300を使うにあたり、差分となる情報もお出しできればと思います。」と最後に書きました。 ヤマハ スイッチの中でSWX2300のみ、以下の機能を有しています。

  1. L2MSによるL2MSスレーブの運用
  2. CiscoライクなコマンドによるCLI運用

今回は後者のCLIについて、Cisco Catalyst実機とコンフィグを見比べることで、実際にどのように設定していくのかご紹介したいと思います。

2. SWX2300とヤマハ ルーターのCLIについて

ヤマハ ルーター(RTシリーズ)では、オリジナルのCLIであり、独特ではありますが(私見ですが)直感的なコマンドとCLI内による日本語のヘルプが特徴です。

一方、SWX2300では、Cisco SystemsのネットワークOS「IOS」に似ているCLIが採用されています。このCLIを、一般的には「シスコライク(のCLI)」と称しています。
Cisco IOSはネットワーク業界でのエンジニアの指標ともなるCCENT/CCNA/CCNP/CCIEといった試験に用いられ、Cisco Systemsのネットワーク機器に採用されており、とても普及しているネットワークOSでもあります。
これにより、Cisco IOSに知見のあるエンジニアは、少々の応用でSWX2300を使用する事が可能となります。

3. ラボ構成

ヤマハ SWX2300-16G、およびCisco Catalyst2940にて、実際に以下の設定を行い、動作試験(単体試験・結合試験)が完了した際のコンフィグを見比べる事により、いかに容易にSWX2300が設定可能か検証します。

  • スパニングツリーの無効化
  • 未使用ポートのshutdown
  • LACP(リンクアグリゲーション・Port-Channel)の構成

【図:ラボ構成】
4. コマンド入力モードについて

シスコライクな一部の機器ではコマンド入力モード(モードの推移)がカスタマイズされているものもありますが、SWX2300では特に意識することなくコマンドを利用可能です。
以下の図は、SWX2300のコマンドリファレンスから該当の図を引用したものです。

2.4.1 コマンド入力モードの基本
http://www.rtpro.yamaha.co.jp/RT/manual/swx2300/Cmdref.pdf

また、併せてdoコマンドも利用可能であり、グローバルコンフィグレーションモード、および個別コンフィグレーションモードから、特権EXECモードのコマンドを直接実行する事が可能です。以下は、個別コンフィグレーションモードからコンフィグを保存する例です。

SWX2300(config)#int ge1
SWX2300(config-if)#do copy run sta
Building configuration...
[OK]
SWX2300(config-if)#

また、上記の図にはありませんが、Ctrl+Zといったショートカットキーも使用可能です。

5. コンフィグ対比(スパニングツリー編)

スパニングツリーを無効化するコンフィグです。
IOSではVLAN ID全てに対しSTPを無効化するような記述に対し、SWX2300ではSTPの機能そのものを停止する記述です。

SWX2300Catalyst2940
spanning-tree shutdown
!
no spanning-tree vlan 1-4094
6. コンフィグ対比(未使用ポートのshutdown編)

STPを無効化した場合、未使用ポートへ誤って挿線した場合のループ発生等の危険性がある為、環境によっては運用上、未使用の全てのポートをshutdown(無効化)する場合があります。
スパニングツリーを無効化するコンフィグです。
IOS・SWX2300ともに、明示的にshutdownコマンドを投入します。

SWX2300Catalyst2940
interface ge3
 switchport
 switchport mode access
 shutdown
!
interface FastEthernet0/3
 shutdown
!
7. コンフィグ対比(LACP編)

今回、SWX2300とCatalyst2940は、LACP(IEEE802.3ad)という標準のリンクアグリゲーションプロトコルを使い、ポート冗長を行います。
Catalyst2940は100Base-TXのスイッチですので、それに合わせるようspeedおよびduplexを明示的に指定します。

SWX2300Catalyst2940
interface po1
 switchport
 switchport mode access
 no shutdown
!
interface ge1
 switchport
 switchport mode access
 no shutdown
 channel-group 1 mode active
 speed-duplex 100-full
 lacp timeout long
!
interface ge2
 switchport
 switchport mode access
 no shutdown
 channel-group 1 mode active
 speed-duplex 100-full
 lacp timeout long
!
interface Port-channel1
 switchport mode access
 flowcontrol send off
!
interface FastEthernet0/1
 switchport mode aceess
 speed 100
 duplex full
 channel-group 1 mode active
!
interface FastEthernet0/2
 switchport mode access
 speed 100
 duplex full
 channel-group 1 mode active
!
8. おわりに

いきなりリンクアグリゲーションの設定は敷居が高かったかもしれませんが、純粋なシスコライクのL2スイッチとしてみた時、SWX2300は設定の敷居の低いスイッチであることが理解できたかと思います。
ヤマハ スイッチは、L2MSの他は独自のプロトコルや設定は少ない印象であり、いわゆる方言に慣れれば使いやすいスイッチだと思います。
また併せて、SWX2300-16Gまではファンレスである為、故障率がとても低いほか、会議室やスタジオといった騒音にとても敏感な環境でも安心して使用できます。