津村彰氏のコラム「LANマップと他社製スイッチの組み合わせを解説」

ヤマハ ルーターでは、標準機能でLANの状況を確認できる「LANマップ」という機能を搭載しています。
また、対応するスイッチ・無線アクセスポイントを組み合わせる事で、ネットワークの状況をぱっと見で確認する事ができます。

しかし、ネットワークの増築の場合、「既に他社製品が動いてるんだけど、そう設計したらいいんだろう?」と思う方も多いです。
今回は、LANマップを既存のネットワーク製品と組み合わせる場合をご紹介したいと思います。

■ ポイントは「Native VLAN」

LANマップのプロトコル「L2MS」は、Native VLAN(VLANタグの無し)のL2パケットです。
一般的なアンマネージドスイッチの場合、VLANタグをスルー(透過)し、宛先MACアドレスを観てスイッチングします。よって、そのまま接続すれば問題無い場合が多いです。
他社製品のマネージドスイッチがある場合は、コツが必要です。

■ ヤマハ製品を使う時のポイント

もし、マネージドスイッチを使用している場合、LANマップを使用するにはデザインにコツが必要です。
Native VLANを管理用セグメントとして使用するよう設計すると良いでしょう。
ヤマハ製品の場合、Native VLANにはL2MSの他、Web管理画面などの通信、無線アクセスポイント間の通信、といったものが流れます。
例えば、以下のように論理ネットワークをデザインする事で、L2MS・LANマップと他社製品を運用する事も可能です。

Cisco IOS製品の場合、中間となるスイッチに以下のようなコンフィグを投入します。
WebマネージメントのL2スイッチでも、同様の設定で動作する場合が多いです。


interface GigabitEthernet0/0
description VID100-SWX2200
switchport mode trunk
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 100
no shutdown
!
interface GigabitEthernet0/1
description VID100-SWX2200
switchport mode trunk
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 200
no shutdown
!
(中略)
interface GigabitEthernet0/15
description RTX1210-LAN1:8
switchport mode trunk
switchport trunk encapsulation dot1q
witchport trunk native vlan 1
switchport trunk allowed vlan 100,200,300
no shutdown
!

■ LANマップからヤマハ製品を管理する

LANマップを使用してデザインすると、個別に機器のIPアドレス・パスワードを管理する必要が無い他、DHCPで自動的にアドレッシングした場合でも、LANマップ上で自動的に機器を認識します。
しかし、現実には「アドレッシングを忘れていた!」「DHCPを使用していない」といった場合も少なくありません。
この場合、L2MSを使用しルーター上から初期設定を行う事で、IPアドレスの設定・変更が可能です。ここではL2パケットを使用しており、L3通信は行っておりません。

■ 相対パスではなくMACアドレスで管理

ルーターのコンフィグでは、L2MS対応の機器は経路による指定(相対的な指定)が出来なくなります。
この場合、対象となるスイッチのMACアドレスを指定する事で運用が可能です。


L2MSの詳細については、以下のページを参照してください。
http://www.rtpro.yamaha.co.jp/RT/docs/swctl/

■ おわりに

今回は、ヤマハのLANマップと、他社ネットワーク製品を組み合わせるポイントをご紹介しました。
他社製品との組み合わせはサポート出来ない場合がありますが、参考にしてください。