津村彰氏の「SWX3100をCLIで設定してみよう!」

1.  SWX3100をCLIで設定してみよう!

前回のコラムで、ヤマハ L3スイッチ「SWX3100-10G」に、「LANマップ」と既設ネットワークに追加する為の「VLAN設定」、「ルーティング設定」をウェブ管理画面より行いました。

今回は、同様の設定をCLIから設定してみましょう。

さて、SWX3100にはシリアルコンソールポートが備わっており、従来のシリアル端子(RJ-45)の他、ミニUSBケーブルでの接続も可能です。また、ウェブブラウザの代わりにTelnetによるCLI操作も可能です。

ミニUSBポートはWindows 10標準ドライバでCOMポートとして認識され、TeraTermといった一般的なターミナルエミュレータで動作しました。万が一コンソールケーブルに不備があった際の為に、ミニUSBケーブルも用意しておくと良いかも知れません。

2.  SWX3100のCLIは、SWX2300シリーズを踏襲

SWX3100のCLIは、SWX2300シリーズと同じくCiscoライクなCLIになります。

具体的な操作方法については以前のコラムに譲りますが、一般的なCiscoライクなCLIの設定経験のある方には、さほど難しくありません。

コラム:ヤマハで社内LANを構築・運用してみよう!  第7回 SWX2300をCLIで設定してみよう

https://www.scsk.jp/product/common/yamaha/special/column_07.html

2.1.   新規に追加されたコマンドについて

SWX3100シリーズでは、LANマップ(L2MS)・ルーティング・DHCPサーバー等追加された機能のコマンドが追加されており、今回一部のコマンドを使用します。

これらはSWX3100で新規に追加されたコマンドとなり、今後のファームウェアアップデートにより機能等が追加・変更になる場合があります。予めご了承ください。

2.2.   L2MSのステータス表示について

L2MSのステータスは、マスターとして動作している際、コマンド「show l2ms detail」で取得可能です。

L2MSの状態表示については、RTX1210/RTX830のものより簡易となっており、本格的にCLIでL2MSを運用する場合には、L2MSマスターにRTX1210/RTX830を採用した方が良いでしょう。

SWX3100#show l2ms detail

Role : Master

 

[Master]

Number of Terminals   : 0

 

[Slave]

Number of Slaves      : 1

[ac44.f2xx.xxxx]

Model name          : WLX202

Device name         : WLX202_xxxxxxxxxx

Route               : port1.2

LinkUp              : 1

Uplink            : 1

Downlink          : None

Config              : None

Appear time         : Sun Apr  1 11:32:23 2018

Number of Terminals : 3

 

3.  設定の保存・初期化

まず、前回のコラムの内容を実践された方は、設定の保存や初期化について、操作が必要です。

 

CLIでは、startup-configを削除し、reloadする事で初期化されます。

SWX3100#erase startup-config

Succeeded to erase configuration

SWX3100#reload

reboot system? (y/n): y

 

また、CLIでの設定の保存は、以下のコマンドとなります。

SWX3100#copy run running-config startup-config

Succeeded to write configuration

 

4.  L2MSマスターの有効化とDHCPサーバーの有効化

まず、LANマップを有効化する為に、L2MSマスターの有効化と、DHCPサーバーの有効化・設定を行います。

 

4.1.   L2MSマスターの有効化

L2MSマスターの有効化には、コンフィグレーションモードで以下の通り設定を行います。

SWX3100(config)#l2ms configuration

SWX3100(config-l2ms)# l2ms role master

Apply the configuration change, you need to restart the system.

SWX3100(config-l2ms)# terminal-watch enable

SWX3100(config-l2ms)#!

SWX3100(config-l2ms)#

SWX3100(config-l2ms)#exit

コメントにもある通り、有効化には再起動(reload)が必要となります。

特権モードで、以下の通り再起動を行います。

SWX3100#reload

reboot system? (y/n): y

 

4.2.   DHCPサーバーの有効化

DHCPサーバーの設定は、「サービスの有効化」「DHCPプールの設定」「DHCPサーバーを有効にするVLANインターフェースへの設定」の3つに分かれます。

SWX3100(config)#dhcp-server enable

 

SWX3100(config)#dhcp pool vlan1

SWX3100(config-dhcp)# network 192.168.100.0/24

SWX3100(config-dhcp)# range 192.168.100.2 192.168.100.191

SWX3100(config-dhcp)# default-router 192.168.100.240

SWX3100(config-dhcp)# dns-server 8.8.8.8

SWX3100(config-dhcp)# dns-server 8.8.4.4

SWX3100(config-dhcp)#exit

 

SWX3100(config)#interface vlan1

SWX3100(config-if)#dhcp-server enable

SWX3100(config-if)#exit

 

DHCPサーバーについては、再起動の必要なく適用されます。

 

5.  VLANの作成及びアドレッシング

VLANについては、事前にVLAN Databaseで宣言されたVLANに対し、VLANインターフェースを作成する事が可能です。

 

まず、VLAN Databaseで、新規に作成するVLANを宣言します。

SWX3100(config)#vlan database

SWX3100(config-vlan)# vlan 21 name VLAN21

SWX3100(config-vlan)#exit

VLAN Databaseは、コンフィグ上にて管理され、別途管理ファイル等は作成されません。

 

次に、VLANインターフェースを作成し、IPアドレスを割り当てます。

SWX3100(config)#interface vlan21

SWX3100(config-if)# no switchport

SWX3100(config-if)# ip address 192.168.1.240/24

SWX3100(config-if)# no shutdown

SWX3100(config-if)#exit

L3スイッチでは、ルーターと異なり物理インターフェースに直接IPアドレスをアサインする事は出来ません。その為、VLANを作成し、VLANインターフェースにIPアドレスをアサインする必要があります。

 

最後に、ポートにVLANをアサインします。
今回はUntagged(ネイティブVLAN・アクセスポート)として設定を行います。

SWX3100(config)#interface port1.8

SWX3100(config-if)#switchport mode access

SWX3100(config-if)#switchport access vlan 21

SWX3100(config-if)#exit

 

なお、ネイティブVLAN及びタグVLANを指定する場合の例は、以下の通りです。

interface port1.7

switchport

switchport mode trunk

switchport trunk allowed vlan add 21

no shutdown

 

switchport modeの種別に「private-vlan」が追加されております。これについては、今後の記事で触れたいと思います。

SWX3100(config-if)#switchport mode ?

access        Set the Layer2 interface as Access

private-vlan  Private-vlan mode

trunk         Set the Layer2 interface as trunk

 

6.  静的ルートの追加

今回、デフォルトゲートウェイとして「192.168.1.1」を追加していますが、以下のコマンドにより投入可能です。

SWX3100(config)#ip route 0.0.0.0/0 192.168.1.1

ウェブ管理画面上では「default」という名前で管理されていますが、CLI上では「0.0.0.0/0」 となります。

表記としてはCIDRの他、サブネットマスクによる指定も可能です。この場合、コンフィグ上ではCIDRに置き換えられます。

SWX3100(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.1

SWX3100(config)#show run | i ip route

ip route 0.0.0.0/0 192.168.1.1

 

7.  スパニングツリーの停止

SWX3100シリーズでは、標準でスパニングツリー(MSTP)が有効になっています。

コマンド「spanning-tree shutdown」で停止可能です。

SWX3100#show spanning-tree

% Default: Bridge up - Spanning Tree Enabled  - topology change detected

(snip)

SWX3100(config)#spanning-tree shutdown

SWX3100(config)#do show spanning-tree

% Default: Bridge up - Spanning Tree Disabled  - topology change detected

(snip)

 

8.  おわりに

ヤマハ初のL3スイッチのエントリーモデル「SWX3100」を、今回はCLIから設定を行ってみました。また併せて、いくつかの部分について、詳細を追記しています。

基本的にSWX2300シリーズとCLI操作に殆ど変わりはなく、Cisco Like CLIを扱ったことがあれば、容易にチャレンジ出来る機種です。

 

9.  参考:SWX3100-10Gの初期化直後のコンフィグ

SWX3100-10Gでは、初期化直後、以下のコンフィグが投入されています。

実運用においては、セキュリティ設定や管理用設定などを必要に応じてカスタマイズしてください。

 

SWX3100#sh run

!

dns-client enable

!

interface port1.1

switchport

switchport mode access

no shutdown

!

interface port1.2

switchport

switchport mode access

no shutdown

!

interface port1.3

switchport

switchport mode access

no shutdown

!

interface port1.4

switchport

switchport mode access

no shutdown

!

interface port1.5

switchport

switchport mode access

no shutdown

!

interface port1.6

switchport

switchport mode access

no shutdown

!

interface port1.7

switchport

switchport mode access

no shutdown

!

interface port1.8

switchport

switchport mode access

no shutdown

!

interface port1.9

switchport

switchport mode access

no shutdown

!

interface port1.10

switchport

switchport mode access

no shutdown

!

interface vlan1

no switchport

auto-ip enable

ip address 192.168.100.240/24

no shutdown

!

clock timezone JST

!

http-server enable

http-proxy enable

!

telnet-server enable

!

line con 0

line vty 0 7

!

end